Как мне установить Clang версии 3 в 10.10?

Как бы я идти об установке версии 3 в Clang/LLVM С в Ubuntu 10.10? В Ubuntu 10.10 устанавливает версии 2.8 по умолчанию. Версия 3 имеет более обширный/до даты поддержка C++ и, возможно, с (я не совсем уверен, о c). Я знаю, что я мог скомпилировать из исходников, но было интересно, если есть НПА или другой способ, чтобы избежать компиляции его из исходных текстов.

Если я компиляции из исходных кодов я должен сказать ему, где найти СТД библиотеки C и т. д. или это автоматически делается.

+657
T3db0t 18 мар. 2017 г., 12:46:55
29 ответов

Я использую Ubuntu 8.10 и хотите обновить ее до 12.04.

Я загрузил 12.04 с сайта Ubuntu и сожгли как образ ISO для CD в DVD (потому что это 701.3 МБ).

Когда я вставляю этот диск в свой дисковод для установки, он не загружается. Появляется пустой черный экран.

В 8.10, когда я нажимаю на обновление до 9.04 он показывает некоторые ошибки. В Ubuntu 8.10 не так хорошо, как 12.04. Пожалуйста, друзья, помогите мне решить эту проблему. Я хочу установить Ubuntu 12.04 на свой ПК.

+893
leoflower 03 февр. '09 в 4:24

Вы должны запустить Testdisk на диске, исправить таблицу разделов. Вы можете установить Testdisk, введя :

судо apt-получить установку testdisk

Запустить testdisk с sudo :

команду sudo testdisk

И следуйте шаг за шагом инструкции здесь : http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

Это довольно легко и в кратчайшие сроки ваш диск будет исправлена и вы сможете смонтировать разделы.

+853
Hindol Ganguly 23 июл. 2016 г., 12:31:46

Возможные Дубликаты:
Как мне установить Ruby на Rails?
Как я могу получить “Рубин”, чтобы делать то, что “наследником пакетов ruby1.9.1” делает?

Я установил Руби 1.9.3-p125 с РВМ. РВМ список дает

Рубин-1.9.3-p125 [ x86_64 с ]

РВМ использовать 1.9.3-p125 дает

Используя /usr/доли/рубиново-РВМ/драгоценные камни/рубин-1.9.3-p125
Запуск /usr/доли/рубиново-РВМ/крючки/after_use

Однако, Рубина-версия - это Руби 1.8.7, (что Руби является /usr/Бен/Рубин).

У меня тоже есть два исполняемых файла: наследником пакетов ruby1.8 и наследником пакетов ruby1.9.1, но ничего не называют наследником пакетов ruby1.9.3 находится на пути.

Как я на самом деле получить Рубин для выполнения наследником пакетов ruby1.9.3 (или, по крайней мере, как я запустить его на всех).

Как только я могу сделать это, я хочу удалить других версий Ruby, поскольку они только занимают пространство.

+815
Cnoland 71 21 дек. 2016 г., 10:24:12

Не так много, PinguyOS базируется на Ubuntu, работает в основном с Ubuntu пакеты и должны быть почти идентичны как Ubuntu под капотом. Но он не развивается и не поддерживается в Ubuntu.

Основные различия между PinguyOS и в Ubuntu

  • PinguyOS использует тяжелую оптимальной GNOME3 рабочего стола
  • Устанавливает кодеки по умолчанию, которые не включены в Ubuntu из-за их лицензий
  • Он по умолчанию содержит большое программное обеспечение, которое не устанавливается в Ubuntu по умолчанию объясняя минимум 1.6 ГБ DVD скачать необходимые для установки

В конце концов, помимо лицензий и личный выбор пакетов, некоторые визуальные твики и скрипты, это не отличается от Ubuntu.

Но поскольку спросите Ubuntu имеет дело только с официальными Убунту или Ubuntu ароматы PinguyOS не по теме, на большинство вопросов здесь.

+787
Alex Parenti 15 янв. 2019 г., 10:05:33
  1. Откройте терминал, нажав клавишу Alt+комбинацию клавиш Ctrl+Т.
  2. Логин с корнем, Су
  3. Введите Пасс
  4. Тип команды dpkg-перенастроить клавиатуру-конфигурации
  5. выход

Перезагрузитесь и повторите проверку. Дайте нам знать, если это решает вашу проблему.

+782
pravin 26 мар. 2015 г., 1:05:34

Попробуйте сделать команду sudo apt-получить обновление сначала, а потом попробовать установить. Если это новая установка в VBOX, а затем иногда это необходимо.

Во-вторых, если проблема не устранена, убедитесь, что у вас "главный" активный репозиторий. Вы можете проверить это в синаптическую, что это менеджер пакетов, или зайдя и просмотрев файл/etc/АПТ/источников.список строку, которая есть в архиве Ubuntu зеркало и "основной" на одной линии.

Если ни один из этих вариантов не поможет, и "основной" - это активный, тогда вы можете просто не суметь учитывая ваши ИТ-политик и настроек брандмауэра в вашей корпоративной сети.

+683
Manas 13 мая 2015 г., 1:16:13

Я тоже жду с Ubuntu 11.10, будет медленнее из-за Сети-менеджер. В то время как закрытие похоже на тайм-аут и конец с сообщением

"Нм-диспетчер.действие: поймал сигнал 15, остановки. ..."

Я снял сетевых и настроен мой IP-адрес с помощью интерфейсов в /etc/сети/и сейчас это снова.

+635
TheHiggsBroson 18 нояб. 2012 г., 22:41:38

Запустить

xrandr поближе

Вы похожи на

Экран 0: не менее 320 х 200, ток 800 х 600, максимальное разрешение 1280 x 1280

Разъем VGA подключен монитор 800x600+0+0 (нормальный левый перевернутый правая ось Х ось Y) 376 мм х 301 мм
 1280х1024 60.0 + 75.0 
 1280х960 59.9 
 1152х864 75.0 74.8 
 1024х768 75.1 70.1 60.0 
 832x624 74.6 
 800х600 72.2* 75.0 60.3 56.2 
 640х480 72.8 75.0 66.7 60.0 
 720x400 70.1

 * элемент тока.

Это-список резолюций, которые можно установить. Теперь вы можете изменять с помощью

индекс расширения xrandr -с

индекс-это число, начиная с 0 в качестве первой линии.

Или

xrandr поближе -с ширинахвысота

+627
Nickolai 26 янв. 2016 г., 14:28:55

Я был только в состоянии сделать это вчера с pdfedit. Что я не могу показаться, чтобы выяснить, как хотя делать это скрипт из терминала.

В pdfedit, загрузите документ. Нажмите на значок задать матрицу трансформации странице.

На первой вкладке, нажмите на кнопку Перевести (смены) страницы и установить, какие страницы вы хотите работать на.

На перевод закладке (второй), установить X и/или Y значения переводов.

Нажмите кнопку ОК.

Всего наилучшего!

+529
Mongomeri 9 сент. 2014 г., 17:01:28

По теме в Каире-

Босс с мини-режим Cardapio enter image description here

http://www.webupd8.org/2010/11/cardapio-menu-update-brings-docky.html

+521
Vvarrvvarra 3 янв. 2010 г., 3:49:18
  • Решение: если вы используете единство, при установке программного обеспечения с помощью программного обеспечения-центр (Центр приложений Ubuntu), есть примечание в нижней части окна прошу вас, если вы хотите создать лаунчер единства. Вы можете нажать "Да" или "нет" соответственно.

  • С другой стороны, можно создать какой-либо скрипт, который проверяет лог-файл:

    кот /ВАР/лог/команды dpkg.журнал|grep установленная
    
  • Есть триггеры, но насколько я могу читать, они включены в пакеты Debian:

    человек в Debian-триггер деб-триггеры
    

    (Интересно, как рабочий стол-файл-утилита запускает программу dpkg: обработка триггеры для desktop-файл-утилиты)

    менее /usr/share/doc/dpkg-dev/triggers.txt.gz
    Общ /ВАР/Либ/с dpkg/триггеры/
    
  • Наконец, может быть, вы могли бы использовать подсистема dnotify для вашего скрипта и смотреть в /usr/доли/каталог применений, где .Desktop-файлы сохраняются:

    https://serverfault.com/questions/50127/how-to-automatically-run-a-script-when-the-contents-of-a-directory-changes-in-li

+516
Abdullah Albamim 19 мар. 2018 г., 6:10:11

вы должны сначала отключить драйвера, которые вы установили с жокеем,
и затем вы можете использовать ndisgtk если у вас есть драйвер беспроводной сети для Windows эта программа создаст драйвер для Linux, начиная от драйверов для Windows если это не работает, вы можете видеть это для обнаружения вами беспроводной карты, а затем скачать драйвера от сюда

или, наконец, если те не работали, попробуйте это
судо apt-получить установку прошивки-в43-установщика
или это
судо apt-получить установку прошивки-в43-lpphy-установщика в командной строке


+432
SPARTAN1986 11 мая 2015 г., 19:58:29

Какие алгоритмы разбиения использовать Ubuntu во время установки, это также доступно в качестве отдельного приложения или команды? Это утилита GParted?

+369
Darien 3 сент. 2018 г., 20:32:45

Попробуйте эту, пожалуйста

Загрузиться в Ubuntu и откройте терминал нажмите Ctrl+АЛТ+Т

Затем монтируем раздел с Arch Linux с .. мы предполагаем, что это /dev/sda5, поэтому (вы можете найти его с помощью команды судо и fdisk -л)

гора

судо смонтировать /dev/sda5, поэтому в каталог /mnt 

После обновления жратвы

обновление-жратва судо 

Я почти уверен, что Арч Линукс сейчас признается.

Выше-это временное решение , но когда жратву быть снова обновлен раздел Арч Линукс должен быть установлен, в противном случае не будет признавать его.

Если вы хотите сделать его постоянным , вы можете добавить содержимое арка Linux в файл/boot/grub/с жратвы.cfg и в файле/etc/харч.д/40_custom

Если вы хотите установить Арч Линукс жратву вместо Ubuntu , вы можете загрузить в Arch Linux и сделать

судо жратвы-установка /Дев/СДА

выше команда будет установить grub арки в MBR и не забывайте обновлять его

судо в grub-mkconfig -о /Boot, и/граб/граб.cfg для

+355
Forzexd 18 сент. 2015 г., 6:43:11

Вы можете безопасно удалить любой файл/каталог, имеющий 2.6.38-11 в их имена, так как это не ядро больше. Эти ядра должны быть установлены во время прецедента в Ubuntu установить.

Они должны, как правило, принадлежат к пакету, но, поскольку они не являются, их следует удалить вручную.

Знать, какие файлы устанавливаются с ядром, можно выполнить команду dpkg -L в Linux-образ-3.2.0-29-общий | меньше

Затем вы можете удалить все файлы/каталоги, перечисленных ЛС-1д /{багажника,Либ/модулей,Либ/прошивки usr/доли/док}/*2.6.38-11*

Затем выполните команду sudo обновление-жратва, следует очистить жратвы запись. Если нет, проверьте содержимое файла/etc/харч.д

+350
tedz2usa 23 февр. 2013 г., 23:45:13

Если вы скопировали файлы на жестком диске в Mac OS Х, возможно, что файловая система файловая система HFS+. Linux не поддерживают журналирование в файловой системе HFS+, так что Убунту не установить его автоматически. Поискав в Интернете, я вижу, что есть способы отключения ведения журнала, так что Ubuntu могут установить его, но я не рекомендую делать этого, поскольку решения кажутся мне опасным хаки. На мой взгляд самое лучшее решение-найти друга с компьютером Apple и скопировать файлы по сети.

Чтобы проверить, какая файловая система жесткого диска, выполните следующую команду после подключения: судо и fdisk -л

+335
Optimus Rhyme 17 нояб. 2010 г., 10:26:55

Попробовать индикатор читателя Google http://google-reader-indicator.en.uptodown.com/ubuntu это отличное приложение.

+328
user37924 16 авг. 2010 г., 10:55:38

Не похож ни на одну из выше размещенной команды устанавливает любые темы. Есть еще один сценарий, ax.sh, что делает, и это также предлагает удалить его, если AmbienceX темы были ранее установлены.

Так что, в принципе, вам просто нужно запустить судо ш ax.shкак установить и удалить его.

+327
humasect 6 июн. 2018 г., 13:52:19

Попробуйте этот сайт для инструкции: http://support.mozillamessaging.com/en-US/kb/switching-thunderbird?s=migrating+from+evolution+to+thunderbird&as=s

Я цитирую из этого документа по почте:

  1. Откройте Наутилус.

  2. Откройте ~/.местные/доли/эволюция/почта/локальная где эволюция хранить ваши письма.

  3. Скопировать все файлы без расширений (таких как входящие, исходящие,..) в установке используется thunderbird для хранения почты (что-то вроде ~/.Тандерберд/uk41lql0.по умолчанию/Почта/локальные папки, где вы должны адаптировать uk41lql0.по умолчанию на свои собственные установки).

  4. Запустите Thunderbird, чтобы проверить, что все ваши сообщения были правильно импортированы.

Там также есть инструкциям по переносу контактов (адресной книги). Я не использую календарь эволюции, или молнией, и не знаю, как перенести это.

+286
user5029 3 мая 2016 г., 20:55:55

Используя КВМ я установил виртуальную машину Windows на сервер Ubuntu 11.04. Каждый раз при загрузке виртуальной машины Windows, просит для компакт-диска операционной системы. Но других виртуальных машин Linux загрузится.

Мне нужна виртуальной машине Windows загружалась нормально, как и другие виртуальные машины с Linux. Может ли один помочь?

+280
N Shaikh 28 февр. 2013 г., 6:40:19

Вот мое предложение:

  1. Начните с дефрагментации дисков в Windows. Это означает, что все ваши файлы будут в правильном порядке и, что более важно, что ваши файлы будут все в начале диска. Результатом будет то, что в конце разделов будет иметь никаких больше данных.
  2. Сделайте резервную копию ваших данных в любом случае. Вы, наверное, ничего не потеряете. Но это "хорошая практика".
  3. Раздел D:\ диск. То есть, разделить его на два. Первая часть будет оставаться на D:\ С ваши данные Windows. Другая часть пройдет в Ubuntu, назовем его "sda6" отныне, как я думаю, он будет назван именно так.
  4. Увеличить размер sda4 в части, поскольку размер раздела подкачки должен быть как минимум ОЗУ (память) способности.
  5. Установить Ubuntu. Во время установки, выберите опцию выбора раздела, на который вы хотите установить ; вы выбрали sda6, смонтирован как "/". Формат sda4 в качестве раздела подкачки.

Совет: после установки Убунту, вы все равно можете иметь доступ к вашим дискам Windows и их содержимое, из Ubuntu.

+244
MisterSaad 17 февр. 2015 г., 15:35:43

Ошибка при установке пакета php5-MySQL-сервера. Выглядит как ошибка команды dpkg. Возможно, нарушена упаковка.

Пытался починить сломанную пакет. Переустановил сервер Lamp и все вроде нормально, за исключением возможности установки пакета php5-MySQL расширения, я получаю:

Ошибки возникли при обработке: в php5-MySQL и 

Суб-процесса для dpkg возвращает код ошибки.

Любые идеи с благодарностью.

+237
Mahala 14 июн. 2014 г., 14:38:42

Вы можете поэкспериментировать с несколькими вариантами для программами hdparm команды. В частности:

  • -С <номер> устанавливает время ожидания перед привод поворачивает шпиндель выкл.
  • -М <номер> устанавливает акустический режим управления (этот параметр также помогает в управлении питанием)

Я не отчитываюсь здесь, как значение должно быть выбрано, я позволю вам прочитать это на странице человека.

Тем не менее, я не рекомендовал бы выбирать значения тайм-аута слишком короткий, а до сих пор один из самых подчеркнув, раз на жесткий диск спин-вверх, т. е. лучше оставить на HDD спина немного дольше, в то время как на холостом ходу, чем постоянно выключать и включать, особенно современные, с низким энергопотреблением жестких дисков.

+220
Jukan 19 дек. 2017 г., 6:06:35

Я рассматриваю возвращение gwibber к версии из стандартного РЕПО (в отличие от нестабильной ППА) так что я могу использовать я-меню снова. Однако, я использую твиттер совсем немного, и я ненавижу, чтобы быть хитом с Проблемы с OAuth. Будет ли это безопасным?

+194
pvledoux 3 июл. 2011 г., 6:08:27

Вы наверняка пытаетесь спросить о том, как отойти от единства , вернемся к классической рабочего стола GNOME.

Если это то, что вы хотите задать, вы должны выйти из своего пользователя (от кнопку "Питание" в верхней правой части экрана) и снова войти, после выбора "классического рабочего стола" вместо "Убунту".

+154
MicPlayz 25 июл. 2016 г., 8:55:56

Я установил Skype, но значок не отображается в верхней панели (в трее). Как "лоток-Белый" был снят с интерфейсом dconf, я не могу добавить значок сам.

+111
hmcnally 12 окт. 2019 г., 3:57:49

Я установил Ubuntu-одна на машине с Lubuntu и действительно синхронизация файлов работает для всех папок, которые являются общими.

Моя проблема заключается в том, что в то время как на моей машине с Ubuntu я могу щелкните правой кнопкой мыши папку и пометить его как общий, я не мог найти способ сделать то же самое под pcmanfm.

Единственное решение я нашел, чтобы использовать демона через командную строку:

u1sdtool-создать-папку .

который работает, но немного топорно.... любой способ интеграции в GUI?

+48
codebits 9 февр. 2010 г., 21:12:08

У меня компания Huawei E156 сети HSDPA (3G) с USB-флешки и я сделал следующее, Также он работал для моего samsung 3G мобильный через USB-кабель.

судо apt-получить установку в wvdial

после установки в wvdial введите следующие строки в терминале для редактирования в wvdial.конф

судо команду Gedit /и т. д./В wvdial.конф

Вставить в ваш редактор, следующие строки:

[Дозвона имя]
Модем Тип = Аналоговый Модем
Телефон = *99#
Сети ISDN = 0
Скорость baud = 460800
Имя пользователя = " "
Пароль = " "
Модем = в /dev/ttyUSB0
Init1 = АТЗ
Init2 = в+cgdcont=1,"ip-адрес","ваше название точки доступа"
Тупой Режим = 1

Всякий раз, когда вам нужно подключить просто наберите в терминале

судо в wvdial имя

Теперь вы будете в интернете с молниеносной скоростью. Я думаю, этот метод является менее трудоемким и быстрее, чем другими методами.

+38
Mishka37 2 дек. 2013 г., 5:20:59
  1. Вы должны добавить один тоннель. Проверить эту ссылку

  2. Установите следующие пакеты:

    на Python (2.7.3-0ubuntu2) 
    питон-всем (2.7.3-0ubuntu2) 
    в Python-appindicator (0.4.92-0ubuntu1) 
    питон-Аппорт (2.0.1-0ubuntu10) 
    питон-АПТ (0.8.3ubuntu7) 
    питон-АПТ-общие (0.8.3ubuntu7) 
    питон-aptdaemon (0.43+bzr805-0ubuntu2) 
    питон-aptdaemon-ГТК (0.43+bzr805-0ubuntu2) 
    питон-aptdaemon.gtk3widgets (0.43+bzr805-0ubuntu2) 
    питон-aptdaemon.gtkwidgets (0.43+bzr805-0ubuntu2) 
    питон-aptdaemon.pkcompat (0.43+bzr805-0ubuntu2) 
    Пайтон-система (0.6.30-5ubuntu2) 
    в Python-beautifulsoup (3.2.0-2build1) 
    питон-Каир (1.8.8-1ubuntu3) 
    питон-крипто (2.4.1-1ubuntu0.1) 
    питон-gnomekeyring (2.32.0+для dfsg-1) 
    питон-gnupginterface (0.3.2-9.1ubuntu3) 
    в Python-MySQL-сервера.разъем (0.3.2-1) 
    в Python-OAuth в (1.0.1-3build1) 
    питон-в OpenSSL (0.12-1ubuntu2) 
    питон-парамико (1.7.7.1-2) 
    питон-pycryptopp (0.5.29-1build1) 
    
+35
Lerak120403 21 февр. 2015 г., 8:44:59

Показать вопросы с тегом